sarproz-group

APS – Ext. Dem Option

This topic contains 9 replies, has 2 voices, and was last updated by  seppi-santiago 1 year, 6 months ago.

  • Author
    Posts
  • #1493

    seppi-santiago
    Participant

    Hello,

    According to Timo’s notes, I interpret that the Ext. DEM option is for Height Estimation only.

    However some times I have accidentally ckeched the Ext Dem option, when estimating displacement only(height neglected), and I’ve seen the Connections Processing takes much longer. My question then is, does the Ext. Dem option have something to do also with Displacement Estimation?

    Thanks.
    Santiago

  • #1494

    periz
    Keymaster

    Checking External DEM means removing a phase component proportional to what is written in the external DEM file.
    So, this is not directly related to movement.
    However, you estimate the movement from phase time series. If you remove or not remove a component from the phase values, clearly you are changing your data. As a consequence, the estimated movement will be different.
    About why it may take longer, this is a consequence of the algorithm I implemented. If the phase data are “clean”, with little noise, the algorithm can quickly converge to the solution. If the phase is very noisy, it takes longer to reach a solution (which by the way may be wrong).
    dan

  • #1496

    seppi-santiago
    Participant

    Hi dan,

    Then it is desirable to ckeck it even if estimating displacement only (from what you say I interpret that it is used to remove the topographic phase reding it from my DEM, which in this case is a high-resolution one).

    I have tried to re-process my dataset again with this option checked, and apart from taking too long (~8 hrs) I can’t see the results (display coherence, histogram, etc).

    I enclose the logfile and the lasterror.mat file so that you can take a glance on them.

    Thanks
    Santiago

  • #1497

    seppi-santiago
    Participant

    Lasterror.mat was not attached in the previous message,
    S

    Attachments:
    You must be logged in to view attached files.
  • #1499

    periz
    Keymaster

    If it takes too long,
    as I previously explained, it means that there is something wrong.
    You did not include the log file, it seems the error is happening in a file that has been modified in the last version.
    Anyway, by remotely sensing you case, I think your DEM is containing NaNs.
    If you remember, I told you to check it, since your DEM is not covering the whole area you are processing
    dan

  • #1500

    seppi-santiago
    Participant

    I enclose my log file,

    I remember that when you warned me about NaN values in my DEMI checked it and I converted them to zero.
    When I made that correction I restarted the process again from the external DEM selection to make sure it was updated.

    Santiago

    Attachments:
    You must be logged in to view attached files.
  • #1502

    periz
    Keymaster

    Santiago,
    you need to plot and check the DEM in SAR coordinates

  • #1503

    seppi-santiago
    Participant

    Dan,

    I’ve checked it with the DEM Visualization tool (screenshot attached), finding no NaNs, but according to the manual this displays the DEM in Geo coordinates, which file corresponds to the DEM in SAR coordinates?

    Santiago

    Attachments:
    You must be logged in to view attached files.
  • #1505

    periz
    Keymaster

    “Site Processing”–>[Visulalization tools]–>”View Parameters”–>scroll the list to “Ext. DEM height”–>pick it–>Click “Plot”

  • #1506

    seppi-santiago
    Participant

    Ok, I’ve visualized it and it is wrong, all zero values. The command prompt tells me this:

    ” wrong saturation values!” Must be NaN < Min < Max < NaN”

    I reselected the DEM, I manually re-wrote the GCP and projected again the DEM amplitude in SAR coordinates. Still seeing all zeros in SAR coordinates.

    What should I do?

    Thanks,
    Santiago

You must be logged in to reply to this topic.