sarproz-group

Geocoding

This topic contains 5 replies, has 4 voices, and was last updated by  periz 2 years, 2 months ago.

  • Author
    Posts
  • #956

    espiritocz
    Participant

    Dear Daniele,
    I am afraid I don’t understand how GCP can be properly arranged. I started new project, using default parameters.
    I performed following:
    1. GCP Selection -> Keep Current Orbits -> Write -> Mean Kml…. result: geocoding was shifted around 500 m
    2. Computed External DEM and synth. ampl…. -> back to GCP Selection -> Keep Current Orbits -> Write -> Mean Kml… result: geocoding was shifted around 138 km (!!!) checked DEM – it looked matching the amplitude…
    3. Reset GCP & Orbits, deleted ReflectivityMap.kml -> Auto GCP Through Ext. DEM -> Write -> Mean Kml …. result: geocoding was SHIFTED OF AROUND 180 KM. Computed External DEM – it doesn’t fit the observed area anymore.

    Please can you explain proper steps for correct geocoding? So far I am forced to manually geocode every dataset I am working with.
    Thank you.

    Milan

  • #957

    periz
    Keymaster

    As explained many times to you in person,
    in this forum, in the manual, tutorials and so on,
    the best way to geocode a dataset is precisely manually. In fact, it takes very little to geocode a dataset manually in Sarproz.
    You can check it in the many examples in the tutorials.
    Why?
    1. because there are many sensors for which the orbital parameters are not precise.
    2. because sarproz can manage subpixel positions, precise height estimation, precise geocoding like no other software can -to my current knowledge, derived by my 13 years experience in the field and by all comments from people using it-. So, if you want to use these capabilities, you need a manual input for precise alignment.

    There are other 2 options given in the software:
    – through an external DEM. This clearly works only if your area has a significant topography. If you area is flat, it cannot work. You can use it, and it generally works well when you have topographic features. However, it is not as precise as the manual one by definition.
    – keeping the current orbital parameters. this option is given just if you do not care about a precise geocoding and you want to skip this step. if you care, you should not use it.

    future improvements:
    – we will sooner or later consider also the interferometric topographic phase. this may be useful in some cases.
    – at this moment the ext. DEM management is not yet allowing a distinction between geoidal and ellipsoidal height. you have this option in the DEM selection but it is not implemented yet. the reason is that up to now it never made a difference. we will conclude the implementation just to improve the rough geocoding through current orbits. however, if you want a precise geocoding, you need a manual point.

    so, if you care about it, learn how to do it manually. if you learn it, it takes very little.

  • #974

    seppi-santiago
    Participant

    Hello Daniele,

    I’m working with an area where I find it difficult to identify a clear and reliable GCP (it’s a totally uninhabited zone) and there is not no topographic feature which could discriminate easily from its surroundings. It is more or less a flat scene at a very high altitude (more than 4000 meters) , with only one hill or peak. In this case the selection through my external DEM could work well?

    I enclose the MasterArea.kml so that you can see how it is

    Thanks,
    Santiago

    PD: When trying to run the External DEM option, I have the same problem I mention here http://www.sarproz.com/groups/sarproz-group/forum/topic/sparse-points-selection/

    • #975

      seppi-santiago
      Participant

      I enclose .zip and .jpg

      Attachments:
      You must be logged in to view attached files.
    • #977

      Yuxiao
      Moderator

      Hi Santiago,

      Dan will be quite busy these days so let me try to answer your questions.

      1. You can try use the external DEM in this case. There is one simple judgement to whether your geocoding went well. After geocoding, geocode your reflectivity map into Google Earth kmz file, and check in Google Earth if it is geocoded well. If it is then you can continue, otherwise, I should suggest method No.2 :

      2. I can see that you’re cropping a very small area out of a whole image. Generally speaking there is always a better chance to find some geocoding point when you enlarge your area. If all your method fails for a small area I would suggest cutting a bigger area from the very beginning.

      For the other questions regarding the masks, I am not able to answer the question without the knowledge of your mask file…

      yuxiao

  • #978

    periz
    Keymaster

    given the infos you posted,
    I expect the geocoding through external DEM to work well

You must be logged in to reply to this topic.