sarproz-group

import sentinel 1A data

This topic contains 18 replies, has 5 voices, and was last updated by  Yuxiao 2 weeks, 4 days ago.

  • Author
    Posts
  • #2126

    krzych1234
    Participant

    Hi,
    How to import sentinel 1A data?

    My soure image is TIFF format,it’s in a folder called ”S1A_IW_SLC__1SDV_20170319T073316_20170319T073344_015758_019F18_2569” ,its original name is s1a-iw1-slc-vv-20170420t045223-20170420t045248-016223-01ad22-004.tiff .

    So I put image in folder “SLC” : /C/Users/Krzychu/Desktop/SLC/S1A_IW_SLC__1SDV_20170319T073316_20170319T073344_015758_019F18_2569/,and set the working directory.But it didn’t work .

    First identified directory: /C/Users/Krzychu/Desktop/SLC/S1A_IW_SLC__1SDV_20170319T073316_20170319T073344_015758_019F18_2569

    get_dir_slc: no known format recognized in directory /C/Users/Krzychu/Desktop/SLC/
    I don’t know how to solve this problem.

    Thanks.

  • #2127

    periz
    Keymaster

    All satellite data come in a specific format.
    The format is not only about the file containing the data.
    Format may include also subdirectories and additional meta data.
    You should never touch such structure and never separate original files.
    In particular Sentinel data are organized in directories whose name terminates with .SAFE
    and they have subdirectories called “annotation”, “measurement”, “support”, …
    If you are working in linux, you can place tar files in the SLC folder, the sw will do the rest.
    If you are working in windows, extract the data in the SLC folder preserving the directory structure.
    best

  • #2128

    krzych1234
    Participant

    I do not know if I understood correctly.
    I work in windows. So I do not have to create “SLC” directories. All I’m putting in to directory, whose name terminates with .SAFE ?
    I did that and it didn’t work.

    What are corrently directories structure?

    • #2129

      Yuxiao
      Moderator

      when you download your Sentinel SLCs, create your own directory for data, like, “TEST”, then inside this folder create a new one called “SLC”, and put either all the .zip files of Sentinel inside, or the zipped folders, ended in “.SAFE” inside the SLC folder. then read the “TEST” folder in sarproz.

    • #2436

      cp02
      Participant

      Hi! I followed all the instructions but I cannot import S1A data.
      I put the zipped folders, ended in “.SAFE” inside the SLC folder. The SLC folder is inside a folder called TEST:
      D:\TEST\SLC\S1A_IW_SLC__1SDV_20170904T050435_20170904T050502_018221_01EA10_A12F.SAFE
      Please, in attachment you will find the error message.
      Thanks.

    • #2437

      periz
      Keymaster

      can you please send error and log again?
      no need to rar them

    • #2438

      cp02
      Participant

      Thanks.

      Attachments:
      You must be logged in to view attached files.
    • #2441

      periz
      Keymaster

      please update your code http://sarproz.com/manual/manage_version.html and try again

    • #2442

      cp02
      Participant

      I’m sorry, but when I click on “Check online”, another error message is created.

      Please, in attachment you will find it.
      Thank you.

      Attachments:
      You must be logged in to view attached files.
    • #2448

      periz
      Keymaster

      please check your email

    • #2449

      cp02
      Participant

      It works. Thank you for your assistence.

  • #2133

    krzych1234
    Participant

    It works 🙂 Thanks for help.

  • #2477

    mhrnciar
    Participant

    Hello!

    I’m trying to process 23 Sentinel-1A images. I’d created folder named ‘S1_DATA’, inside this folder I created ‘SLC’ folder. All of the images I downloaded into ‘SLC’ and unzipped them as I’m working on windows machine.

    In ‘Select Dataset’ I chose directory to the parent folder (D:\S1_DATA\) and the ‘SLC DATA Processing’ window popped up. I unchecked Untar and Del tar options, but when I clicked on ‘Get Contents’ I got error saying “can not find SENTINEL xml file!”.

    Full error message together with most recent .log file are in attachchments.

    Any help will be much appreciated.

    Matus

    Attachments:
    You must be logged in to view attached files.
  • #2480

    mhrnciar
    Participant

    Hello!

    I’m trying to process 23 Sentinel-1A images. I’d created folder named ‘S1_DATA’, inside this folder I created ‘SLC’ folder. All of the images I downloaded into ‘SLC’ and unzipped them as I’m working on windows machine.

    In ‘Select Dataset’ I chose directory to the parent folder (D:\S1_DATA\) and the ‘SLC DATA Processing’ window popped up. I unchecked Untar and Del tar options, but when I clicked on ‘Get Contents’ I got error saying “can not find SENTINEL xml file!”.

    Full error message together with most recent .log file are in attachments.

    Any help will be much appreciated.

    Matus

    Attachments:
    You must be logged in to view attached files.
    • #2483

      Yuxiao
      Moderator

      Are your folder structure identical to what I demo here?

      https://www.dropbox.com/s/k4odh9ye4k422in/Screenshot%202017-09-29%2019.12.36.png?dl=0

      yuxiao

    • #2484

      mhrnciar
      Participant

      Thank you for the quick answer.

      This is what my structure looks like.

      Attachments:
      You must be logged in to view attached files.
    • #2486

      Yuxiao
      Moderator

      Please email me your log file at qyuxiao@sarproz.com.

      Due to a recent wordpress problem I am not able to see your log file here on forum.

      yuxiao

    • #2487

      mhrnciar
      Participant

      I’ve sent it to you.

    • #2488

      Yuxiao
      Moderator

      Just to note for other’s reference, this problem has been solved.

      It appears that one of the SLC folders was corrupted and does not contain the xml file that is required for reading in meta data.

      In the next version of sarproz we will add a folder integrity check for Sentinel Tops folder inside the SLC folder for data import purpose.

You must be logged in to reply to this topic.