sarproz-group

loading TOPS data problem

This topic contains 9 replies, has 4 voices, and was last updated by  carolina 7 months ago.

  • Author
    Posts
  • #2274

    qingli
    Participant

    hello, everyone. I am loading the TOPS data. here attached the lasterror.mat and site.log files.
    When i want to do the master image extraction.
    The description in matlab is listed as the following:
    Processing the SLC data Preparation

    Using 12 workers

    Extracting Master Image

    processing Sentinel Subswath nr 2

    SLC data extraction

    An error occurred and was saved in the file lasterror.mat, directory /home/ql/SARproz/pcodes_2016-11-24

    If you need assistance, please include the file lasterror.mat

    You may include also file 19_Jun_2017_16_46_41_sarproz.log

    Here a glimpse:

    Attempt to reference field of non-structure array.

    31 Slave images have not been extracted!!

  • #2275

    periz
    Keymaster

    hi qingli please zip and attach mat and log files

  • #2280

    Yuxiao
    Spectator

    The error is fixed and the new version is uploaded.

    Q

  • #2292

    qingli
    Participant

    i already zip these two files. please have a look.
    thanks,
    Qingli

  • #2293

    qingli
    Participant

    i already zip these two files. please have a look.
    here is the attachment
    thanks,
    Qingli

    Attachments:
    You must be logged in to view attached files.
  • #2303

    qingli
    Participant

    hello,yuxiao, here is still the problem of loading TOPS data .
    i attached the log. and last error. mat file and please have a look with them.
    Thanks,
    Regards.

    here is the reminder in the matlab.

    Extracting Master Image

    processing Sentinel Subswath nr 1

    SLC data extraction

    An error occurred and was saved in the file lasterror.mat, directory /home/ql/SARproz/pcodes_2016-11-24

    If you need assistance, please include the file lasterror.mat

    You may include also file 23_Jun_2017_08_56_48_sarproz.log

    Here a glimpse:

    Attempt to reference field of non-structure array.

    31 Slave images have not been extracted!!

    Attachments:
    You must be logged in to view attached files.
  • #2305

    Yuxiao
    Spectator

    June 19, 2017 at 3:49 pm
    The error is fixed and the new version is uploaded.
    Q

  • #2871

    carolina
    Participant

    Hi everyone 🙂
    I’m trying to use the program to generate DEM. But unfortunately, at the very beginning I have problems, when loading data in the SLC Data Processing window, the following message appears:
    1 Slave images have not been extracted!!
    Because of this I can not do the first step which is co-registration.
    I created the appropriate data folder:
    C:\Users\kowczarz\Desktop\Data2\SLC\S1A_IW_SLC__1SDV_20170531T161052_20170531T161119_016828_01BFA2_DACF.SAFE
    \S1A_IW_SLC__1SDV_20170706T161054_20170706T161121_017353_01CFA7_F5C4.SAFE
    I work on two satellite scenes, VV polarization, subswath 1. I did not change the data structure of the sentinel, I unpacked the whole file to the SLC folder.Attached are files with errors.
    I am asking for help, because I have no idea where I am making a mistake.

    Carolina

    Attachments:
    You must be logged in to view attached files.
  • #2874

    periz
    Keymaster

    It looks like you are missing the Matlab Signal Processing Toolbox.
    You can use the compiled version instead
    best

  • #2875

    carolina
    Participant

    I understand the unfinished.
    I should use Mathlab Compiler? https://www.mathworks.com/products/compiler.html

You must be logged in to reply to this topic.